Locked History Actions

deegreeCompatibility

This is a one-stop overview of deegree compatibility.

All empty rows still need to be filled in! Please do so.

Software

deegree 1

deegree 2

deegree 3 *

Runtime JRE 1.4

{OK}

{OK}
(when compiled with JDK 5 -target 1.4)

{X}

Runtime JRE 1.5

{OK}

{OK}

{X}

Runtime JRE 1.6

{X}

Compiler JDK 1.4

{OK}

{X}

Compiler JDK 5

{OK}

{OK}

Compiler JDK 6

{OK}

Tomcat 4.1

{OK}

{OK}

Tomcat 5.0.x

{OK}

{OK}

Tomcat 5.5

{X}

{OK}

Tomcat 6.x

{OK}

deeJUMP 1.0

{OK}

{X}

OpenJUMP

{X}

{OK}

PostgreSQL

{OK} tested: 8.2, 8.3, 8.4

PostGIS

0.8 (only)

version > 0.9 supported; 1.0.3 tested

{OK} tested: 1.2, 1.3, 1.4

Oracle

MySQL

{X}

SQLServer

{X}

* There is a more detailed description available on system requirements for deegree 3.

There are also lists of supported (OGC) Web Services in deegree2 and deegree3.


CategoryDeegree2 CategoryDeegree3